Arduino bibliotheksverwalter fehler beim herunterladen

June 11, 2020 admin

Hallo. Ich habe eine neue Kopie der IDE installiert, aber weiterhin diesen Fehler beim Öffnen des Board-Managers erhalten. Ich habe Anweisungen im Forum befolgt, um das Problem zu beheben, aber nichts funktioniert. Ich führe Windows 10 aus. Ich kann von meinem Browser aus auf diese URL zugreifen. Ich bin in der Lage, einige der Boards zu installieren, die im Board-Manager aufgeführt sind, aber die meisten geben Fehler, wenn sie versuchen, zu installieren. Ich habe es funktioniert (art-off) durch Kopieren aller drei Bereiche (Programmdateien, Bibliotheken und der Arduino15 Ordner) vom funktionierenden Laptop auf diesen Computer. Zumindest kann ich damit arbeiten, aber der ursprüngliche Fehler tritt immer noch darin auf, dass beim Öffnen des Board Managers oder des Bibliotheks-Managers dieser Fehler am unteren Rand des Fensters in rot angezeigt wird, der besagt, dass ein Fehler beim Öffnen der json-Datei aufgetreten ist. Aber im Osten sind die Bibliotheken und Tafeln, die ich brauche, da. @DSiwi können Sie downloads.arduino.cc/libraries/library_index.json von einem Browser ohne Fehler erreichen? Und welche Version der IDE werden ausgeführt? Da wir java jre bündeln, verwenden wir keine systemweiten Zertifizierungsstellen; Eine alte Version der IDE konnte nicht alle SSL-Zertifikate überprüfen, die von Behörden freigegeben wurden, die zum Zeitpunkt der Kompatibilität unbekannt waren (z. B.

Lassen Sie uns verschlüsseln), aber es hatte immer noch einen Fehler. Ich weiß nicht, was ich tun soll! Ich verglich auch “package_index.json” mit te konservierte alte (datiert Januar 2020) und fand, dass die neue Datei jetzt enthält die folgenden zusätzlichen Pakete: arduino-beta, Arduino megaAVR Boards 1.8.6 (zusätzlich zu t 1.8.5), Arduino nRF528x Boards (Mbed OS), avr-gcc 7.3.0-atmel3.6.1-arduino7 (zusätzlich zu 7.3.0-atmel3.6.1-arduino5. Die Lösung der Bearbeitung von arduino.l4j.ini von plasma-vision löste das Problem für mich. In meinem Fall verwende ich einen Arbeits-Laptop, der Cisco Umbrella hat und mit jedem Netzwerk ausfallen würde. Mit den zusätzlichen zwei Linien funktioniert es jetzt überall für mich, vielen Dank für den Rat. Kopieren Sie einfach die Proxy-Einstellung des Unternehmens auf ArduinoIDE>preference>NetworkTab. Es funktioniert. Sie können Den Bibliotheks- und Denleitungsmanager verwenden. Fehler beim Herunterladen downloads.arduino.cc/packages/package_index.json java.lang.RuntimeException: java.lang.Exception: Fehler beim Herunterladen downloads.arduino.cc/packages/package_index.json unter cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda-onUpdatePressed-19(ContributionManagerUI.java:151) unter java.lang.Thread.run(Thread.java:745) Verursacht durch: java.lang.Exception: Fehler beim Herunterladen downloads.arduino.cc/packages/package_index.json unter cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:113) unter cc.arduino.contributions.packages.ContributionInstaller.download(ContributionInstaller.java:330) unter cc.arduino.contributions.packages.ContributionInstaller.downloadIndexAndSignature(ContributionInstaller.java:305) unter cc.arduino .contributions.packages.ContributionInstaller.updateIndex(ContributionInstaller.java:283) at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda-onUpdatePressed-19(ContributionManagerUI.java:147) …

Could not resolve host: urls.api.twitter.com